weird no-start problem - Page 4 - Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums



NA (1989-1997) NA Miata discussion within. The MX5's first generation, the NA, sold over 400,000 units from 1989 to 1997.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-24-2012, 08:17 PM   #31
MFz Lurker
Thread Starter
 
Join Date: Jul 2011
Location: A2, MI
Posts: 25
Default

Well, yesterday I took the plugs out and checked the compression. I unplugged the coil power, and removed the fuel pump fuse so as not to waste gas and flood it. It was 170-180 or so all 4, that was good. Today I was going to work on it - wanted to see if there were any shorts or sparking in the engine. I replaced everything, turned off the lights in the garage and... it started! !!1! Not sure why, but I've been cleaning up engine grounds and doing stuff, totally unclear why though.

The vacuum leak is worse but now I've tracked it down to needing a new throttle body gasket.

Wow. Just, wow.

So I think it's back! For now anyway, as I'm not sure why it ran, I'm not sure it will stay running.
Drew is offline   Reply With Quote
Old 02-25-2012, 04:48 AM   #32
BAMFr
 
Track's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 1,789
Default

this sounds like it maybe an electrical problem, perhaps with the cas/cps (whatever is on your car) or some sort of electronic that would control your fuel/spark completely.
Track is offline   Reply With Quote
Old 03-01-2012, 12:18 PM   #33
MFz Lurker
Thread Starter
 
Join Date: Jul 2011
Location: A2, MI
Posts: 25
Default

Well it's still running. I'm sure working on the grounds did the trick. I cleaned a lot of grease of the back ground where much of the electronics connect to the motor. I am finding vacuum leaks the biggest of which was a dry pcv grommet. Running rough though, working on that, hopefully chasing vacuum helps that. Changed the oil too, i tphink it suffered from so many failed starts. Probably won't post again on this thread so thanks!
Drew is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird ticking in my miata.... julekpl NA (1989-1997) 3 03-20-2013 06:00 PM
HELP! 92 won't start Bsullymtp NA (1989-1997) 6 08-17-2012 08:31 PM
Died on road, won't start. dieselmiata NA (1989-1997) 24 03-17-2012 08:29 AM
Weird buttons. dieselmiata Off Topic Discussion 24 01-14-2012 01:16 PM
P0402 EGR and weird Idle Track NB (1998-2005) 13 10-11-2011 06:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:31 PM.