Weird ticking in my miata.... - Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums



NA (1989-1997) NA Miata discussion within. The MX5's first generation, the NA, sold over 400,000 units from 1989 to 1997.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-12-2013, 01:08 PM   #1
MFz Lurker
Thread Starter
 
Join Date: Aug 2012
Location: St. Augustine
Posts: 32
Default Weird ticking in my miata....

Hello, here is julekpl again. I am having a slight issue with this ticking sound coming from my 1990 miata. I know it is not from the belts, and I do change my oil ever 3000 miles so I know that would cause any issues. The ticking starts after I drive around a bit, when I stop my car, put it in park, and then I put it in drive again, that's when it starts. It hasn't caused any problems, but I would like prevent it from causing any. Anyone have an idea on this issue? And my engine is stock.
julekpl is offline   Reply With Quote
Old 03-13-2013, 02:00 PM   #2
MFz Regular
 
Join Date: Dec 2012
Location: Irvine, CA
Posts: 90
Default

If it is coming from behind your left shoulder it is most likely the electric fuel pump. Not the a very quiet pump, if you didn't hear it your car would not be running! If it is from the engine area, then it could just be the sound that comes from things just heating up a bit and then cooling down.
fxpthl64 is offline   Reply With Quote
Old 03-20-2013, 07:15 AM   #3
Moderator
 
sixshooter's Avatar
 
Join Date: Jul 2011
Location: Tampa, FL; Lake Jackson (Atlanta), GA
Posts: 1,894
Default

Does the crankshaft pulley wobble at all when it is running?

Hydraulic lifter noise is common in these cars even sometimes with fresh oil. What oil do you use? How many miles on the car? What is your hot oil pressure reading?
sixshooter is offline   Reply With Quote
Old 03-20-2013, 07:00 PM   #4
MFz Lurker
Thread Starter
 
Join Date: Aug 2012
Location: St. Augustine
Posts: 32
Default

Well mine is an automatic, and from what I know, the crankshift is not wobbling, and I use a 5w20 oil that I don't remember the brand name of. It has 87k original miles on it, and usually while running it gets around 60 for the oil pressure, a bit less maybe. I know that it's not the belts, and that it is behind them, deeper in the engine, and is sometimes it get loud, where it sounds like the belts.
julekpl is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
weird no-start problem Drew NA (1989-1997) 32 03-01-2012 01:18 PM
Weird buttons. dieselmiata Off Topic Discussion 24 01-14-2012 02:16 PM
P0402 EGR and weird Idle Track NB (1998-2005) 13 10-11-2011 07:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.