92 cruise control - Page 2 - Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums



NA (1989-1997) NA Miata discussion within. The MX5's first generation, the NA, sold over 400,000 units from 1989 to 1997.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-01-2012, 12:46 PM   #11
BAMFr
 
Track's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 1,789
Default

if the light isn't on, then its the cruise control unit.
Track is offline   Reply With Quote
Old 03-01-2012, 12:47 PM   #12
Red To Go
Thread Starter
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Fuse, where should I look for wiring issues?
RedTurboMiata is offline   Reply With Quote
Old 03-01-2012, 01:43 PM   #13
Red To Go
Thread Starter
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

i think i may have 1 of the following problems.
1.fuse
2. switch is disconnected
3a. module disconnected
3b. module is gone.
4.clutch switch is bad
RedTurboMiata is offline   Reply With Quote
Old 03-01-2012, 01:46 PM   #14
BAMFr
 
Track's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 1,789
Default

there is a brake switch also.

btw, I looked for a cruise control fuse and couldn't find one...
Track is offline   Reply With Quote
Old 03-01-2012, 01:50 PM   #15
Red To Go
Thread Starter
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Quote:
Originally Posted by Track View Post
there is a brake switch also.

btw, I looked for a cruise control fuse and couldn't find one...
i know there is a brake switch but i think it is part of the brake light one as well and the lights come on when you tap the brake.
RedTurboMiata is offline   Reply With Quote
Old 03-01-2012, 02:00 PM   #16
BAMFr
 
Track's Avatar
 
Join Date: Jul 2011
Location: NC
Posts: 1,789
Default

I see, must be the cruise switch thats my problem then. I will have to look into getting a replacement.
Track is offline   Reply With Quote
Old 03-01-2012, 02:01 PM   #17
Red To Go
Thread Starter
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

i think it might be the clutch switch or the main switch.
RedTurboMiata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Cruise control skip47 How To... 1 04-14-2015 06:09 AM
OEM Cruise Control Help Needed Andyb NB (1998-2005) 1 01-05-2014 02:56 PM
My NA stopped during a mountain cruise Mattseg Pictures and Videos 2 09-11-2013 08:26 AM
First post...search on this forum a little buggy....Cruise and A/c problems monizuki NA (1989-1997) 3 07-02-2013 11:03 AM
g2g cruise in MD to Philly Suhhmanthalynn Local Meets, Events and Tech Days 0 01-09-2013 02:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:45 AM.