Regulator - Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums
Miata Forumz - Mazda Miata Chat Forums



NA (1989-1997) NA Miata discussion within. The MX5's first generation, the NA, sold over 400,000 units from 1989 to 1997.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-02-2013, 01:21 AM   #1  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default Regulator

Hello all....This is my first post here....been looking around and see a lot of good stuff here.

I unloaded a 97 miata off my trailor today. Got a killer deal on it and couldnt pass it up. This will be the first 4 banger I have ever owned. Mainly corvette and mustang background.....so here is the question.

I cant get it to start...will crank and crank and no fire...got it from a dude who has no engine knowlege and did a motor swap...he couldnt get it to run so he got rid of it. used to run cause I drove it but he blew it up....a long story for another post.

I have spark, everything apears to be hooked up correctly. I unhooked fuel line from pump/tank and hit key and I have gas spewing. I unhooked return and cranked it over and nothing comming out. Is my regulator a problem? I would assume that when engine dosent start the fuel would go right back to the return.

Thanks for any responce.

-B-
Krown Kustoms is offline   Reply With Quote
Old 01-02-2013, 12:02 PM   #2  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

any check engine lights? what year motor was put in it?
RedTurboMiata is offline   Reply With Quote
Old 01-02-2013, 11:31 PM   #3  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

To be honest I have no idea what year....I am only assuming its a 1.8. How would I tell? Like I said I have absolutly no experience with anything smaller than a v8 except maybe an oil change or two.

When key is on all the lights are on. Including check engine light. I read somewhere to jump pins in the diag port for engine light to blink codes but I cant find where I saw it.

I have been messing with it off and on throughout the day and have spark and plugs are wet with fuel....I think now it might be a timing issue. Is it possible to get the cam trigger 180 out? I also cant find timing marks on the crank pulley. I know they're there somewhere.....wonder if it jumped time while the head was off.

Thanks -B-
Krown Kustoms is offline   Reply With Quote
Old 01-03-2013, 05:27 AM   #4  
MFz Regular
iTrader: (1)
 
Join Date: Jul 2011
Location: Wayne, NJ
Posts: 115
Default

If the head was off and the timing belt was not done correctly, you need to start over. It could very well be the source of your problems.
olderguy is offline   Reply With Quote
Old 01-03-2013, 06:23 AM   #5  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

there are a few different ways to tell but i think, the best way to tell if its a 1.6 or a 1.8 is the location of the coil pack. the 1.6 is on the driver side of the block and the 1.8 is on the passenger side. i agree with the timing belt conclusion, and it might be worth noting that the cam/crank sensor could be 180 out as well.

1.8


1.6
Attached Thumbnails
Regulator-abe0c18c-97b5-4b09-a8bf-0ef8869a68c9-33755-00002e014ad8fb02.jpg   Regulator-896bf5e7-efa9-4255-89a4-4bcd988bd14a-1471-000002906685114f.jpg  
RedTurboMiata is offline   Reply With Quote
Old 01-03-2013, 08:53 AM   #6  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Thanks guys....I do believe it is a 1.6 and I know for sure the sensor was swaped but not sure about the head...gunna start over. I hate picking up where someone left off.

From what I gathered from the pics the firing order is 3214 on the 1.6 and 4123 on the 1.8.....correct? is this because the coil pack is in backwards on one or the other? Ill have to go look but I dont think mine is either configuration.

Ill send a pic of the mess Im working with in a few

Gunna start looking around to find proper timing belt procedure.

Again thanks

-B-
Krown Kustoms is offline   Reply With Quote
Old 01-03-2013, 11:50 AM   #7  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Attached Thumbnails
Regulator-3f63f644-8252-49f4-b7f1-5b4da7d04d4e-8228-00000b98fa898584.jpg  
RedTurboMiata is offline   Reply With Quote
Old 01-03-2013, 03:53 PM   #8  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Thanks....got it

It is a 1.8....wrong mental picture. I got it to start on starting fluid but only that...using a dmm I saw voltage blips when I tried to fire it up at the #4 injector plug so I think they are firing.

I think Im back to the regulator again. I ordered an adjustable one last night and hope it gets here soon. Dosent make sense to me that fuel wont come out of the return side of rail with the line off and engine not using the fuel.

-B-
Krown Kustoms is offline   Reply With Quote
Old 01-03-2013, 04:06 PM   #9  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Here is the demon
Attached Thumbnails
Regulator-0101131206.jpg   Regulator-0102131304.jpg   Regulator-0103131634.jpg   Regulator-0103131635.jpg   Regulator-0103131635a.jpg  

Krown Kustoms is offline   Reply With Quote
Old 01-03-2013, 07:16 PM   #10  
MFz Regular
iTrader: (1)
 
Join Date: Jul 2011
Location: Wayne, NJ
Posts: 115
Default

Quote:
Originally Posted by Krown Kustoms View Post
Thanks....got it

It is a 1.8....wrong mental picture. I got it to start on starting fluid but only that...using a dmm I saw voltage blips when I tried to fire it up at the #4 injector plug so I think they are firing.

I think Im back to the regulator again. I ordered an adjustable one last night and hope it gets here soon. Dosent make sense to me that fuel wont come out of the return side of rail with the line off and engine not using the fuel.

-B-
Could be that you have the lines reversed. The hard line toward the front of the car is the return and should be coming off the end of the rail at the FPR.
olderguy is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:07 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.