Regulator - Page 2 - Miata Forumz - Mazda Miata Chat Forums

NA (1989-1997) NA Miata discussion within. The MX5's first generation, the NA, sold over 400,000 units from 1989 to 1997.

Regulator

Old 01-03-2013, 10:50 PM
  #11  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

So lemme get this straight......the return line comes off the regulator and feed line goes directly to the rail?
Krown Kustoms is offline  
Old 01-03-2013, 11:46 PM
  #12  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Originally Posted by Krown Kustoms View Post
So lemme get this straight......the return line comes off the regulator and feed line goes directly to the rail?
yes sir
RedTurboMiata is offline  
Old 01-04-2013, 12:22 AM
  #13  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

That was it! Thank all of you for helping.

Now I gotta get timing right and all the little stuff.

I cant believe it was that simple...

now time to get to making it look good.
Krown Kustoms is offline  
Old 01-04-2013, 12:18 PM
  #14  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

cool glad it was something easy.
RedTurboMiata is offline  
Old 01-04-2013, 04:54 PM
  #15  
Moderator
 
sixshooter's Avatar
 
Join Date: Jul 2011
Location: Tampa, FL; Lake Jackson (Atlanta), GA
Posts: 1,901
Default

...And there was much rejoicing...
sixshooter is offline  
Old 01-04-2013, 10:40 PM
  #16  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Well....now there is an aweful tick in the head/cam area....figures there would be something....idled it for about half hour and no change....almost sounds like stuck lifter.

Check engine light still on too.

Set the timing and idles nicely....rev it a bit and let off and the backfire pops make cool looking smoke rings. Of course after engine warmed up that went away....34 degrees i believe.
Krown Kustoms is offline  
Old 01-04-2013, 10:52 PM
  #17  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Originally Posted by Krown Kustoms View Post
Well....now there is an aweful tick in the head/cam area....figures there would be something....idled it for about half hour and no change....almost sounds like stuck lifter.

Check engine light still on too.

Set the timing and idles nicely....rev it a bit and let off and the backfire pops make cool looking smoke rings. Of course after engine warmed up that went away....34 degrees i believe.
Obd1 or 2, if its two get the codes read. the ticking is a common miata thing. Change the oil 10w30, throw some oil stabilizer in it. Should stop after a while.
RedTurboMiata is offline  
Old 01-05-2013, 07:06 PM
  #18  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Obd1 or 2.....not sure what you mean.

What type of stabilizer would you recomend?
Krown Kustoms is offline  
Old 01-05-2013, 07:22 PM
  #19  
Red To Go
 
RedTurboMiata's Avatar
 
Join Date: Jul 2011
Location: Canton, MI
Posts: 2,601
Default

Does it have the port for a code reader, mine is just hanging out near the radio surround.
I like this stuff
Attached Thumbnails Regulator-1efdd1e2-73eb-4658-9654-2fcf307dc361-9842-00000dd8f95bf518.jpg  
RedTurboMiata is offline  
Old 01-05-2013, 09:24 PM
  #20  
MFz Lurker
Thread Starter
 
Join Date: Dec 2012
Location: Good ole' Virginia
Posts: 24
Default

Not sure...Ill have to look.

I definatly know lucas....not sure why that didnt ring a bell.
Krown Kustoms is offline  

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.